Status
Get in touch
Back
Maintenance
Database upgrade maintenance
Completed 6 Oct at 06:00pm UTC.
Affected services
API
Completed
Maintenance completed
Posted 6 Oct at 06:00pm UTC.
Started
We will upgrade the backend Database servers.
Posted 6 Oct at 04:00pm UTC.